How to solve gem conflicts

I had a gem conflict when I tried to run a Sinatra app that I recently created.

Unable to activate sinatra-contrib-1.4.6, 
because sinatra-2.0.0 conflicts with sinatra (~> 1.4.0) (Gem::ConflictError)

How do we solve this?

We have this conflict because sinatra-2.0.0 conflicts with other sinatra gem versions. We need to uninstall to solve this conflict. In this case, sinatra-2.0.0.

1. Uninstall

gem uninstall sinatra

2. Gives selection of current sinatra gems to uninstall

Select gem to uninstall:
 1. sinatra-1.4.6
 2. sinatra-1.4.7
 3. sinatra-1.4.8
 4. sinatra-2.0.0
 5. All versions

3. Choose

> 4

4. Done

Successfully uninstalled sinatra-2.0.0

 

*  5. Repeat until all conflicts are solved